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What is Codebook
Encrypted Data Vault

Guards passwords and private data

Keeps sensitive information organized

Enables quick recall of secrets

Syncs data across multiple devices 
automatically or on demand

● iOS (iPhone / iPad)
● Android
● Windows
● macOS



Security

256-bit AES encryption

Peer-reviewed storage engine

Data Protection:

● Encrypted at rest on device
● Encrypted in transit during sync
● Encrypted at rest on all cloud 

services
Data encrypted with your 

Sync Key and Master 
Password



Getting Started



Master Password
Setup your Master Password on first 
use

It’s required each time you access 
your Codebook data.

Your Master Password is used to 
encrypt your data on your device.  It is 
not stored in Codebook.

Recommendations:
- at least 8 characters including 1 of 
each, capital, number, lowercase, and 
special character, ex: ! $ ?
- Complex and difficult to guess

***  You must remember your Master 
Password.  It cannot be of Codebook  

***



Initial View Layout
1. Toolbar
2. Search
3. Category List
4. Entry List
5. Entry View
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Data model
Category

● Groups records
● Navigation-based retrieval

Entry

● Record with multiple fields; or
● A multi-line note 

Category

Entry



Data model
Fields

● Store related data on an Entry
● e.g. username, password

Labels

● Define the Field type
● Establish behavior (e.g. launch 

email, generate password)

Field

Label



Create a Category
1. New Category (or shift+⌘+N)
2. Enter a descriptive name
3. Choose an Icon
4. Click Create Category
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Create an Entry
1. New Entry (or ⌘+N)
2. Enter Descriptive Name
3. Choose Icon
4. Add Fields

a. Choose Label
b. Enter field value

5. Click the “Favorite Star” to mark 
important entries as Favorites

6. Click “Edit” to Save changes
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Special Labels & Behaviors
● Password / PIN

○ Masked
○ Supports random generation
○ Weakness warnings are displayed when passwords are entered

● Note
○ Free text entry

● Website
○ Launches browser on double click

● Email
○ Launches email client on double click

● 2-Step Code
○ Generates time-based one time passwords (e.g. for Google 2-step)



Create a Note
1. Add Note Entry (or 

option+⌘+N)
2. First line becomes title
3. Multi line text content
4. Save note

SEARCH WITHIN A NOTE:
There are 2 ways to activate search: 
a - Edit -> Find -> Find
b - Shift + ⌘ + F 
Enter the search criteria in the search 
bar. The first occurrence will be 
highlighted.  Hit return to move to the 
next occurrence.

2

3

4

1
4

a



Deleting records
1. Delete selected category or 

entry
(Deleting a category also  
deletes all entries)

2. Delete field:
a - Edit
b - Click minus

Be careful not to lose information, 
these operations cannot be undone.
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Navigation and Retrieval



Categories
Navigate through your own custom 
organization structure

1. Choose a Category from the 
navigation area

2. Choose an Entry to view

Categories and Entries are sorted 
alphabetically

1

2



Favorites
Entries marked with the Favorite star 
are quickly accessible

1. Click on Favorites
2. Click on an Entry
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Search
Quick retrieval of information based on 
keyword:

1. Enter search criteria
2. Choose Entry to view

Entry names and all field values are 
included in search.
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Copy / Paste
Data can be copied to the clipboard

1. Click on Field to be copied
2. Click the copy button -or- type 

⌘+C
3. Paste into another app with 

⌘+V

The clipboard is managed and fields 
you copy will be cleared automatically.

1

2



Secret Agent



Secret Agent
Global keyboard shortcut to launch 
Codebook search from any app

Insert data into an active text field (e.g.  
a website password in your browser)

Available on Desktop Only



Use
1. Press  SHIFT + CMD + \
2. Enter search term
3. Use up and down arrows or 

mouse to navigate results
4. Press return to select a search 

result
5. Arrow down or up to select a 

Field (like Password)
6. Press return to enter value to 

active text field in another app

Tip: Favorite entries will sort to the top 
in Secret Agent.



Synchronization



  Synchronization
Codebook can keep data in sync across 
multiple devices.  

Changes made on any device can be merged.

All devices to be synced share the same Sync 
Key.  Your Sync Key is generated once and 
used for all of your devices.

You select the method to be used to sync your 
devices.

Types of Syncing:
      1. Codebook Cloud **
      2. Cloud Service (Google Drive or  
          Dropbox)
      3. Desktop WiFi

** Codebook Cloud is a subscription service 
that automatically syncs your devices as 
changes are made.

Sync Using 
Codebook 
Sync Key

Mobile

Desktop

New data and 
changes are merged 

across Codebook 
apps

One Sync Key is used for all 
devices being synced



Create Codebook 
   Cloud Account

Codebook Cloud is an optional subscription 
service that automatically syncs your changes to 
all of your signed in devices.

You can create a Codebook Cloud account during 
Codebook installation or from the Codebook 
Settings Menu.

During Installation:
1 - Enter your email
2 - Click continue then follow instructions
                OR
After Installation from Sync Preferences:
1 - Codebook -> Settings
2 - Sync tab
3 - Sync Service - Codebook Cloud
4- Automatically Sync with Codebook Cloud
5 - Click Sign In then follow instructions

For More Info: 
https://www.zetetic.net/codebook/documentation/create-codeb
ook-cloud-account/?platform=macos

During
Installation:

From 
Codebook
Settings:



Initial Sync Key Setup 
If you created a Codebook Cloud 
account during installation, your Sync 
Key has already been created.

If you need to create a Sync Key, 
select Setup Sync Key from the Sync 
Menu

Since this is your initial Codebook 
setup:
Click No 

Your new Sync Key will be generated

** A new Sync Key is generated 
only once and needs to be 
imported to ALL other devices. **

** There is only one the sync key that 
    is used for ALL of your devices.  **



Backup Sync Key 
    Your Sync Key is needed to encrypt and decrypt 
your data when syncing your devices.  You should 
generate a backup of your Sync Key so you can 
retrieve your data in the event that your device is lost 
or damaged.

Options for creating a Backup Sync Key:
1. Print a Backup Code
    - a QR code representing your Sync Key 
encrypted with your Master Password
*** Be sure to write down your Master Password of the 
device generating the backup in the space provided ***
2. Write Down Word List
    - a list of 20 words that can be used to generate 
the same encryption key that is stored in your Sync 
Key. 
Master Password not required to decrypt a Word List
3. Save As File
    - creates a file that can be copied to another 
device for backup or import
## Master Password required to decrypt the file - be sure 
to keep a record of it ##

*** write your Master Password***
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enter location to 
save file
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Import an Already 
Existing Sync Key 

During Installation 
During initial setup, you will be given the 
option to Scan your Sync Key

  1 - Click Scan Sync Key
  2 - Scan Backup QR Code
  3 - Enter Master Password for Sync Key
  4 - Click Submit
  5 - Confirmation of Successful Import

To import your Sync Key after installation, 
select Setup Sync Key from the Sync 
menu
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Import an Already 
Existing Sync Key 

1. From the Sync Menu, tap Setup Sync Key
2. Since you already have a Sync Key, click 
Yes and you will be prompted to scan your Sync 
Key.   

To import your existing Sync Key you can scan it 
from another device or from a printed copy.
To Display Sync Key from the desktop app:-
        Sync menu > Add a Device 
To Display Sync Key from mobile device: - 
        Sync View > Add a Device 
 This will display a QR code containing an encrypted 
representation of your Sync Key. 

3. Click Scan Sync Key and scan the displayed 
QR code to store it in the new device.  You then 
need to enter the Master Password used when 
the sync key was generated.

   ** There is only one sync key that 
       is used for ALL of your devices.  **
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Import an Already 
Existing Sync Key

(continued)

Scan Sync Key:
- Scan the QR code using your 
computer’s camera
- Enter the Master Password that was 
used when the Sync Key was created
- Click Submit



Import an Already 
Existing Sync Key

(continued)

Enter Word List to 
Import  Sync Key 
- Enter the 20 words in the Word List in 
order
- Click Done

Import  Sync Key File
If you select the Import a Sync Key file 
option, you will be prompted to select 
the location of the file *
- Click Import Sync Key

* the file was created with the name 
Codebook.synckey

Word 
List:

Import File:



  Set Sync Preference
1. Select Codebook -> Settings

2. Select your Sync Service from the drop down 
list.  

SYNC NOTES:
You need a Codebook Cloud subscription to 
automatically sync your devices

Authenticate with the service once and allow 
Codebook to link to your personal cloud account

Desktop WiFi sync is initiated from the iOS or 
Android device

NOTE:  even if you only use Codebook on one device, 
Syncing your data creates an encrypted backup copy of 
your data in a cloud service which will allow you to restore 
your data in case your device is lost, damaged or stolen.
** You will need a Backup Sync Key to restore your data.



  Codebook Cloud 
Synchronization

Codebook Cloud is a subscription sync 
service that allows you to make 
changes to your Codebook records on 
multiple device and it will automatically 
keep them up-to-date

All of your devices must have 
Codebook Cloud selected as the sync 
preference and be signed in to the 
same Codebook Cloud account.

** The same Sync Key is used for all of 
your devices **

Codebook 
Cloud

Mobile

Desktop

Sync is triggered on 
each device as 

changes are made

Changes are stored in 
a central copy 



  Cloud Service 
Synchronization

Data can be synced using your  
Dropbox or Google Drive account

All data on the Cloud is encrypted 
using your Sync Key

When syncing using a cloud service, 
the sync process must be initiated 
from each device to ensure all 
changes are made on all devices.

Syncing is done with one Cloud 
Service at a time

** The same Sync Key is used for all of 
your devices **

Cloud Service

Mobile

Desktop

Sync is triggered on 
each device on 

demand

Changes are stored  
in the central copy on 

the Cloud



    How to sync using 
   a Cloud Service

1. Tap the Sync button
2. Sign in to your Google Drive or 

Dropbox account to authenticate
3. Sync will proceed after 

authorization

Tip: Sync periodically to keep your data 
in sync across your devices.
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Cloud Service Sync example
Computer

 1.   Add a new entry in Codebook Desktop
 2.   Start Sync
 3.   Changes copied to Cloud Service

  9.  Start Sync
10.  Mobile changes merged from Cloud 
       Service to Codebook Desktop 

Mobile Device

4.   Start Sync
5.   Codebook Desktop changes merged from
      Cloud service to Codebook Mobile
6.   Edit Entries on Codebook Mobile
7.   Start Sync
8.   Mobile changes copied to Cloud Service



Sync Using
 Desktop WiFi 

WiFi Sync will merge new data and 
updates on both the desktop app and 
the mobile device

Both devices must have the same 
Sync Key

WiFi Sync is started on the mobile 
device

Both devices must be connected to the 
same WiFi network to be able to sync

Mobile

Desktop

Data will be merged 
and updated on the 

mobile device and the 
desktop

Sync is triggered on 
the mobile device



Important Preferences



Customize Labels
Add new custom labels

Customize behaviors

Enable masking

Available under File -> Customize Labels 
(or ⌘+L)



Autolock

Leaves application unlocked for a 
designated period of time (default 5 
minutes)

Automatically locks application when 
timer expires

Allows more convenient access 
without repetitious logins

Tip: Be careful; when autolock is 
enabled your data is exposed.

Available under Codebook menu -> 
Settings -> Locking



Data Detection
Data Detection allows you to interact with 
websites, phone numbers, dates and more 
within Note Entries.

1. Allow data detection in notes:
 Codebook menu -> Settings -> General
2. When in edit mode hovered over the  data 
that can interact. Right click to show the 
available options. 

Examples:
Dates, Flight Numbers, Addresses, Email, 
Websites, Phone Numbers
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Options for 
a link

Options for a 
phone number



Clipboard clear
Codebook automatically wipes secrets 
from the system clipboard after 2 
minutes.

Available under Codebook menu -> 
Settings -> General



Password Review
When the Preference is set, you can review 
your passwords with 
HaveIBeenPwned.com.   The review will 
take place as a new password is entered.  

You can also review a password on an 
existing entry:

1. Right click on a password field.  The
    Password Options Menu will be  
    displayed.
2. Click Review Password.
    Codebook will let you know if any 
    breaches have been found.

OR
Use the Keyboard Shortcut - 

⬆+⌘+R 
To perform Password Review  

1 - Right 
Click
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Secret Agent
1. On Settings Menu, check 

“Enable Secret Agent with 
keyboard Command”

2. Click the “Choose User Scripts 
Folder” button

3. Codebook will choose the 
correct folder, simply click 
“Choose User Scripts Folder” 
again

4. Choose the key sequence to 
launch Secret Agent

1

2

3

4



Other Features



Password Change
Available under Codebook menu -> 
Change Master Password



Magnify a Field
To Magnify a field in an entry:

1. Right click on a field.  The
    Field Options Menu will be  
    displayed.
2. Click Magnify [field type].
3. The value of the field will be displayed in 
a large font.
    

1- Right 
Click
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